Ticket #10048 (closed Bug: fixed)

Opened 5 years ago

Last modified 5 years ago

locales/zh_TW/LC_MESSAGES/plonefrontpage.po is not UTF-8 complilant

Reported by: tyam Owned by:
Priority: minor Milestone: 4.0
Component: Internationalization Version:
Keywords: Cc:

Description

PloneTranslations/locales/zh_TW/LC_MESSAGES/plonefrontpage.po file seems to have non-utf8 characters. Make sure the file is properly encoded as utf-8.

Change History

comment:1 Changed 5 years ago by vincentfretin

How do you found non-utf8 caracters in the file? I can open the file an it seems properly utf-8 encoded.

Can you please contact the last translator directly and see with him to fix the issue? Please do the same for the other issues you reported, thanks.

comment:2 Changed 5 years ago by tyam

Okay, I will do contact to the related people. For this zh_TW frontpage po file issue, I found this is not true. zh_TW frontpage po file is properly encoded. It was due to the bug of pobuddy.py program and I fixed it. Please refer this email for pobuddy.py.  http://sourceforge.net/mailarchive/forum.php?thread_name=0B221BFE-8A50-428D-86AC-BA73B7A3F5B8%40mac.com&forum_name=plone-i18n When you check out PloneTranslations from collective svn, you will find pobuddy.py program in utils directory. So, "cd PloneTranslations/utils" and then "./pobuddy.py -av all" will show you all including generating 900 CSV files in pobuddyCSV directory. 'headers.csv' is also good to see. To see help, just type './pobuddy.py -h'.

comment:3 Changed 5 years ago by vincentfretin

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.