Ticket #10509 (closed Bug: fixed)

Opened 5 years ago

Last modified 5 years ago

@@personal-information form breaks on non-ascii input

Reported by: elvix Owned by: esteele
Priority: blocker Milestone: 4.0
Component: General Version:
Keywords: Cc: esteele, khink, sunew


if i enter a non ascii-character in any of the fields in the personal data form at /@@personal-information, Plone chokes with the following traceback.

Traceback (innermost last):
  Module ZPublisher.Publish, line 127, in publish
  Module ZPublisher.mapply, line 77, in mapply
  Module ZPublisher.Publish, line 47, in call_object
  Module zope.formlib.form, line 787, in __call__
  Module zope.formlib.form, line 775, in render
  Module zope.formlib.form, line 739, in resetForm
  Module plone.fieldsets.form, line 33, in setUpWidgets
  Module zope.formlib.form, line 408, in setUpEditWidgets
  Module zope.schema._bootstrapfields, line 171, in get
  Module plone.app.users.browser.personalpreferences, line 184, in get_fullname
  Module plone.app.users.browser.personalpreferences, line 180, in _getProperty
  Module encodings.utf_8, line 16, in decode
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe6' in position 6: ordinal not in range(128)

Verified on both the fullname and location fields, but i assume it applies to all.

Verified on 4.dev after b3 release.

Change History

comment:1 Changed 5 years ago by elvix

  • Cc esteele, khink, sunew added

For the record. Davisagli believed this may be a duplicate of #10447. Note that the problem persists after the closing of #10447 and that the tracebacks are different.

comment:2 Changed 5 years ago by kleist

  • Priority changed from minor to major

Bumping priority, since I live in non-ascii-land.

comment:3 Changed 5 years ago by esteele

  • Priority changed from major to blocker

comment:4 Changed 5 years ago by esteele

  • Status changed from new to assigned
  • Owner set to esteele

comment:5 Changed 5 years ago by davisagli

  • Status changed from assigned to closed
  • Resolution set to fixed

(In [37020]) make sure we don't break if we get a unicode value for a property, fixes #10509

comment:6 Changed 3 years ago by davisagli

  • Component changed from Infrastructure to General
Note: See TracTickets for help on using tickets.