Ticket #10896 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

collections controlpanel weird behaviour

Reported by: saily Owned by:
Priority: major Milestone: 4.0.1
Component: General Version:
Keywords: upstream TuneUp Cc: frisi

Description

It's not possible to remove collection indexes and/or metadata in portal controlpanel.

Reproduce

Try to remove a index or metadata checkbox on plone/portal_atct/atct_manageTopicIndex or plone/portal_atct/atct_manageTopicMetadata and hit save. This removes the last item every time i hit the save button.

Change History

comment:1 Changed 4 years ago by petschki

i can confirm this. also if you want to add index or metadata fields it doesn't work.

comment:2 Changed 4 years ago by frisi

  • Cc frisi added

comment:3 Changed 4 years ago by petschki

i've just tested the management form and topic tool and it turns out, that the zope http request behaviour of input field type ":records" changed in 2.12 ... maybe a bug?

please follow  https://bugs.launchpad.net/zope2/+bug/619081

comment:4 Changed 4 years ago by kleist

  • Priority changed from critical to major
  • Keywords upstream added
  • Component changed from Unknown to Infrastructure

comment:5 Changed 4 years ago by petschki

  • Status changed from new to closed
  • Resolution set to fixed

ok this is pretty funky: in  http://dev.plone.org/collective/changeset/119766 the order of input fields has changed, so that the checkbox is now the first input field. if its missing, the http request gets messed up.

i've changed the input field order in  http://dev.plone.org/collective/changeset/123670

didn't knew that ... anybody of you?

comment:6 Changed 4 years ago by petschki

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:7 Changed 4 years ago by jessilfp

  • Keywords TuneUp added

comment:8 Changed 4 years ago by petschki

  • Status changed from reopened to closed
  • Resolution set to fixed

fixed in Products.ATContentTypes 2.0.5

comment:9 Changed 22 months ago by davisagli

  • Component changed from Infrastructure to General
Note: See TracTickets for help on using tickets.