Ticket #11092 (closed Bug: invalid)

Opened 4 years ago

Last modified 4 years ago

If Plone folder is copied, buildout deletes wrong "parts" directory

Reported by: dthomas218 Owned by:
Priority: major Milestone: 3.3.x
Component: General Version:
Keywords: buildout upstream Cc:

Description

I created a folder d:\Plone335, ran buildout, it's working fine. Then I copied it to d:\Plone335-staging, and ran buildout on this new folder, which deleted all d:\Plone335\parts subfolders on my production site . Very bad on reboot!

Renaming my staging folder to d:\Plone335staging and running buildout on it worked fine, no deletions.

Therefore something must be concatenating "buildout:directory" to remove everything up to the hyphen when the parts directory is remade.

I don't remember seeing any warnings about using not a hyphen in the folder name.

Change History

comment:1 Changed 4 years ago by kleist

  • Keywords upstream added
  • Priority changed from minor to major
  • Summary changed from Windows Plone folder should not contain a hyphen to [Windows] If name of buildout directory contains hypen: buildout deletes wrong "parts" directory
  • Component changed from Unknown to Infrastructure
  • Milestone set to 3.3.x

Ooops! Nevertheless, hardly a Plone bug. Buildout? or a recipe?

Since this happens on Windows, we can eliminate this potential cause: hyphen is (in some contexts) a reserved character in bash:  http://www.gnu.org/software/bash/manual/bashref.html#index-g_t_002d-75

An interesting experiment would be to try to reproduce this on Linux or Mac OS X. And also to try this with Plone 4.

comment:2 Changed 4 years ago by dthomas218

  • Keywords hyphen removed
  • Summary changed from [Windows] If name of buildout directory contains hypen: buildout deletes wrong "parts" directory to [Windows] If Plone folder is copied, buildout deletes wrong "parts" directory

dthomas218 again, amending my original issue.

This has nothing to do with hyphens. The scenario is this:

  1. Copy a Windows Plone folder (e.g., d:\Plone335) to a target folder (e.g., d:\NewPlone)
  1. Run buildout the first time on the target folder, and the parts folder is emptied in the source folder (e.g. d:\Plone335).
  1. Workaround: You can copy the parts folder back to the source from the target, then run buildout on the source folder, and everything runs fine.
  1. After the first buildout on the target, this does not recur.

comment:3 Changed 4 years ago by kleist

  • Status changed from new to closed
  • Resolution set to invalid
  • Summary changed from [Windows] If Plone folder is copied, buildout deletes wrong "parts" directory to If Plone folder is copied, buildout deletes wrong "parts" directory

Thanks for persevering in your attempts to improve Plone. However, I'll close this ticket on two grounds:

  1. Copying a buildout directory, and expecting everything to work, is hardly a supported action. During buildout, a number of Python files (and other files too?) are constructed which contain absolute paths to directoryies/files in the buildout directory. It's like self-brain-surgery, I'd say.
  1. If, against my assumption, this should be supported, it's not a Plone issue. Please report a bug here:  https://launchpad.net/zc.buildout/+bugs

comment:4 Changed 22 months ago by davisagli

  • Component changed from Infrastructure to General
Note: See TracTickets for help on using tickets.