Ticket #11316 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

Critical error on add user page if one group has an accent in its title

Reported by: thomasdesvenain Owned by:
Priority: critical Milestone: 4.x
Component: Unknown Version:
Keywords: users, groups Cc: vincentfretin

Description

Once a group has been added with a special character in its title (accent), add user page is broken :

Traceback (innermost last):

Module ZPublisher.Publish, line 127, in publish Module ZPublisher.mapply, line 77, in mapply Module Products.PDBDebugMode.runcall, line 70, in pdb_runcall Module ZPublisher.Publish, line 47, in call_object Module zope.formlib.form, line 787, in call Module zope.formlib.form, line 777, in render Module Products.Five.browser.pagetemplatefile, line 126, in call Module Products.Five.browser.pagetemplatefile, line 60, in call Module zope.pagetemplate.pagetemplate, line 113, in pt_render Module zope.tal.talinterpreter, line 271, in call Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 888, in do_useMacro Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 533, in do_optTag_tal Module zope.tal.talinterpreter, line 518, in do_optTag Module zope.tal.talinterpreter, line 513, in no_tag Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 954, in do_defineSlot Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 533, in do_optTag_tal Module zope.tal.talinterpreter, line 518, in do_optTag Module zope.tal.talinterpreter, line 513, in no_tag Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 858, in do_defineMacro Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 946, in do_defineSlot Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 888, in do_useMacro Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 533, in do_optTag_tal Module zope.tal.talinterpreter, line 518, in do_optTag Module zope.tal.talinterpreter, line 513, in no_tag Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 954, in do_defineSlot Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 533, in do_optTag_tal Module zope.tal.talinterpreter, line 518, in do_optTag Module zope.tal.talinterpreter, line 513, in no_tag Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 858, in do_defineMacro Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 531, in do_optTag_tal Module zope.tal.talinterpreter, line 513, in no_tag Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 821, in do_loop_tal Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 533, in do_optTag_tal Module zope.tal.talinterpreter, line 518, in do_optTag Module zope.tal.talinterpreter, line 513, in no_tag Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 742, in do_insertStructure_tal Module Products.PageTemplates.Expressions, line 220, in evaluateStructure Module zope.tales.tales, line 696, in evaluate

  • URL: /home/thomasdesvenain/.buildout/eggs/plone.app.form-2.0-py2.6.egg/plone/app/form/pageform.pt
  • Line 114, Column 30
  • Expression: <PathExpr standard:u'widget'>
  • Names:

{'args': (),

'container': <PloneSite at /site>, 'context': <PloneSite at /site>, 'default': <object object at 0x7fd3997fe4a0>, 'here': <PloneSite at /site>, 'loop': {}, 'nothing': None, 'options': {}, 'repeat': <Products.PageTemplates.Expressions.SafeMapping object at 0xa58f730>, 'request': <HTTPRequest, URL= http://localhost:8280/site/@@new-user>, 'root': <Application at >, 'template': <Products.Five.browser.pagetemplatefile.ViewPageTemplateFile object at 0x8e75950>, 'traverse_subpath': [], 'user': <PropertiedUser 'admin'>, 'view': <Products.Five.metaclass.AddUserForm object at 0xa5bcf50>, 'views': <Products.Five.browser.pagetemplatefile.ViewMapper object at 0xa5bcc90>}

Module Products.PTProfiler.ProfilerPatch, line 32, in patched_call Module zope.tales.expressions, line 217, in call Module Products.PageTemplates.Expressions, line 157, in _eval Module Products.PageTemplates.Expressions, line 119, in render Module zope.app.form.browser.itemswidgets, line 340, in call Module zope.app.form.browser.itemswidgets, line 603, in renderValue Module zope.app.form.browser.itemswidgets, line 508, in renderItems Module zope.app.form.browser.itemswidgets, line 403, in renderItemsWithValues Module plone.app.form.widgets.multicheckboxwidget, line 20, in renderItem Module zope.app.form.browser.widget, line 537, in renderElement Module zope.app.form.browser.widget, line 522, in renderTag

UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)

/home/thomasdesvenain/.buildout/eggs/zope.app.form-3.8.1-py2.6.egg/zope/app/form/browser/widget.py(522)renderTag()

-> attr_list.append(u'%s=%s' % (key, quoteattr(unicode(value))))

Change History

comment:1 Changed 4 years ago by vincentfretin

  • Status changed from new to closed
  • Resolution set to fixed

(In [46389]) Fixed UnicodeDecodeError caused by wrong groups vocabulary (token and value in terms were switched). This closes #11316

Note: See TracTickets for help on using tickets.