Ticket #11690 (closed Bug: fixed)

Opened 3 years ago

Last modified 15 months ago

[Plone 4.2] IE9 JavaScript Error TinyMCE

Reported by: mgraf Owned by: dkozar
Priority: critical Milestone: 4.3
Component: Visual Editor Version: 4.2
Keywords: tinymce, ie Cc: pingviini, mark@…, f.van.dijk@…, yulka, sk.random@…, gaudenzius, rmattb, keul, jbaumann, auspex, timo@…, domen@…, nguyen@…, dimboo, leong@…, davilima6, esteele, ccrownhart

Description (last modified by kleist) (diff)

keul: Agreed. Hopefully, somebody will feel motivated enough to fix it.

Change History

comment:1 Changed 3 years ago by mirella

We have experienced the same problem with IE9 and with the same javascript error. Any idea when TinyMCE of Plone will be updated with the newest TinyMCE 3.4.2? Plone4 uses tinymce 3.2.7 of 22 september 2009. (according to the js file).

comment:2 Changed 3 years ago by pingviini

  • Cc pingviini added

comment:3 Changed 3 years ago by markvl

  • Cc mark@… added

comment:4 Changed 3 years ago by fvandijk

  • Cc f.van.dijk@… added

comment:5 Changed 3 years ago by yulka

  • Cc yulka added

comment:6 Changed 3 years ago by davidjb

  • Cc sk.random@… added

comment:7 Changed 3 years ago by davidjb

Seems this issue affects my version of IE 9 (9.0.8080.16413) and is also present with the IE 10 preview (10.0.1000.16394).

For what it's worth, this issue (at least in my testing) makes editing essentially impossible because selection of editor content with the mouse doesn't work at all in IE 9 and double-click selection (plus trying to use toolbar buttons) don't work in IE 10 preview.

comment:8 Changed 3 years ago by kleist

i'm no friend of IE, but shouldn't this be a blocker?

comment:9 Changed 3 years ago by gaudenzius

  • Cc gaudenzius added

comment:10 Changed 3 years ago by dkozar

As part of GSoC, I'm porting (WIP) latests TinyMCE 3.4.3 release to Products.TinyMCE. No ETA though :)

comment:11 Changed 3 years ago by cwainwright

  • Priority changed from major to critical

What are the changes of this being fixed soon? Using the latest tiny_mce.js (v3.4.3) fixes IE, but breaks the ability to apply span styles from the TinyMCE dropdown, like highlight or discreet. The latest version of Products.TinyMCE (1.2.7) does not work in IE in Plone 4.0.7 or 4.1

comment:12 Changed 3 years ago by rmattb

  • Cc rmattb added

comment:14 in reply to: ↑ 13 Changed 3 years ago by rmattb

comment:15 Changed 3 years ago by rmattb

  • Summary changed from IE9 Javacript Error TinyMCE to IE9 JavaScript Error TinyMCE

comment:16 Changed 3 years ago by keul

  • Cc keul added

comment:17 Changed 3 years ago by keul

I don't know if a ticket must became blocker only if this totally mess up Plone, but IE 9 is starting to became quite common.

We are getting a lot of bug fix request about this. The change of browser compatibility is working for us, but this needs to be fixed.

comment:18 Changed 3 years ago by jbaumann

  • Cc jbaumann added

comment:19 in reply to: ↑ description Changed 3 years ago by dkozar

  • Status changed from new to assigned
  • Owner changed from robgietema to dkozar
  • Description modified (diff)

Replying to mgraf:

Website displays correct, but editing with IE9 is nearly impossible. Updating to current (original TinyMCE) tiny_mce.js solves this!

Message: Object doesn't support property or method 'recalc' Line: 3 Char: 20015 Code: 0 URI: /tiny_mce.js


Message: Object doesn't support property or method 'parentElement' Line: 3 Char: 64632 Code: 0 URI: /tiny_mce.js

comment:20 follow-up: ↓ 21 Changed 3 years ago by dkozar

  • Description modified (diff)

This should be fixed in  https://github.com/iElectric/Products.TinyMCE

Expect a beta release in a week or two!

comment:21 in reply to: ↑ 20 Changed 3 years ago by ajussis

Replying to dkozar:

This should be fixed in  https://github.com/iElectric/Products.TinyMCE

Expect a beta release in a week or two!

Hi,

What's the status of this release? Any experiences on using these changes?

(And yes, for an organization where IE9 is unfortunately de facto this is a blocker...)

comment:22 Changed 3 years ago by auspex

  • Cc auspex added

This isn't working with a current checkout from github. Instead of the original error, I now get:

SCRIPT5009: 'jQuery' is undefined 
tiny_mce_gzip, line 1 character 1

from IE9. Additionally, Chrome warns

Resource interpreted as Script but transferred with MIME type text/html.

comment:23 Changed 3 years ago by timo

  • Cc timo@… added

comment:24 Changed 3 years ago by gaudenzius

I was able to work around this by changing the following line in main_template.pt in our theme:

  • <meta http-equiv="X-UA-Compatible" content="IE=edge" />

+ <meta http-equiv="X-UA-Compatible" content="IE=8" /> This forces IE 9 into IE 8 compatibility mode. It works but is by no means a clean solution...

comment:25 follow-up: ↓ 27 Changed 2 years ago by dkozar

As I see more and more people coming on IRC asking for this fix, I suggest you try 1.3 beta (currently latest) from  http://www.domenkozar.com/2011/10/24/productstinymce-13-beta-1-release/

comment:26 Changed 2 years ago by dkozar

  • Cc domen@… added

comment:27 in reply to: ↑ 25 Changed 2 years ago by keul

Replying to dkozar:

As I see more and more people coming on IRC asking for this fix, I suggest you try 1.3 beta (currently latest) from  http://www.domenkozar.com/2011/10/24/productstinymce-13-beta-1-release/

To be fair to people that will read this comment: yes, the last 1.3 beta fix this issue but right now is limited. Reading the mailing list I found that some new bug has been added, and also there are know issues like: "editing existing link on image does not recognize current link": my users will don't like this at all!

1.3 will be a great release, right now it's better to point that is not perfect!

comment:28 Changed 2 years ago by tkimnguyen

  • Cc nguyen@… added

comment:29 Changed 2 years ago by dimboo

  • Cc dimboo added

comment:30 Changed 2 years ago by kcleong

  • Cc leong@… added

comment:31 Changed 2 years ago by mgraf

tiny_mce.js update to current (3.4.7; releaseDate: 2011-11-03) resolved this bug for me...

comment:32 Changed 2 years ago by davilima6

  • Status changed from assigned to confirmed
  • Cc davilima6 added
  • Version set to 4.1

comment:33 Changed 2 years ago by cleberjsantos

The pull request solves the bug:  https://github.com/plone/Products.TinyMCE/pull/20

comment:34 Changed 22 months ago by tkimnguyen

As I read the above comments, do I understand correctly that this issue is still outstanding?

comment:35 Changed 22 months ago by kleist

  • Cc esteele added

Added the release manager (esteele) to Cc:

comment:36 Changed 22 months ago by kleist

A short test with IE9 in the 4.3 coredev buildout (which currently uses Products.TinyMCE 1.2.12): everything seems to work fine.

This might be because "Products/CMFPlone/skins/plone_templates" contains this:

      tal:define="...
                  dummy python:request.RESPONSE.setHeader('X-UA-Compatible', 'IE=edge,chrome=1');"

No idea if this has been backported to the latest releases of Plone 4.1/4.2.

comment:37 Changed 22 months ago by keul

Yes, the last 4.2 main_template has the same code

comment:38 Changed 22 months ago by keul

A note: I tested the fix above (adding the header and removing the old meta tag) in a Plone 3.3 installation with TinyMCE 1.1.12 and this not fix the problem.

comment:39 Changed 22 months ago by keul

The same on Plone 4.2 (for me, is not working).

@kleist: are you sure of your test? Maybe you manually changed the browser compatibility mode to IE 8.

comment:40 Changed 22 months ago by kleist

I've checked Tools > Compatibility View, and its disabled. Everything seems fine, I've added a link and inserted an image.

However: coredev is no longer using TinyMCE 1.1.12, but the checked out version:

> git remote -v
origin  git://github.com/plone/Products.TinyMCE.git (fetch)

It might be, that this was the case also when I wrote comment 36.

I'm using IE 9.0.8112.16421 on Windows 7 (64 bit).

comment:41 Changed 21 months ago by dkozar

This should work with Products.TinyMCE master branch. Any objections for closing this one?

comment:42 Changed 21 months ago by keul

I tested the buildout.coredev and I activated TinyMCE in a new created site: I still have problem with IE 9.

I'm using IE 9.0.8112.16421 on Windows 7

I get this in the IE console:

SCRIPT438: Object doesn't support property or method 'recalc'
tiny_mce.js, line 3 character 20015

and also:

SCRIPT438: Object doesn't support property or method 'parentElement'
tiny_mce.js, line 3 character 64632

Turning out developer mode in portal_javascript doesn't change anything.

For me the bug is not fixed. No-one else can test this??

comment:43 Changed 21 months ago by dkozar

Using buildout.coredev branch 4.3?

comment:45 Changed 21 months ago by keul

Sorry... switching to 4.3 branch all is working, on IE 7, 8 and 9.


However: you want to simply close the ticket saying "this will be fixed in Plone 4.3"? IE 9 is growing and this bug is still there on Plone 4.2...

I don't think this is a good thing to do...

comment:46 Changed 21 months ago by kleist

  • Version changed from 4.1 to 4.2
  • Description modified (diff)
  • Summary changed from IE9 JavaScript Error TinyMCE to [Plone 4.2] IE9 JavaScript Error TinyMCE

comment:47 Changed 21 months ago by kleist

  • Keywords ie added; ie9 removed

comment:48 Changed 21 months ago by dkozar

TinyMCE 1.3 will be released which can easily be backported to 4.x (current master branch actually also works with Plone 3), that's the beauty of our packaging method :-)

comment:49 Changed 21 months ago by kcleong

Using the latest TinyMCE (1.3-beta2, from github.com) editing and saving works on IE9. I tested this on Plone 4.2.0.1 by adding TinyMCE to the sources.

comment:50 Changed 21 months ago by ccrownhart

  • Cc ccrownhart added

comment:51 Changed 20 months ago by eleddy

confirmed this working on 4.2.1 for anyone who is curious. don't forget to run the upgrade step and everything is beautiful. beta4

Last edited 20 months ago by eleddy (previous) (diff)

comment:52 Changed 15 months ago by kleist

I assume that this ticket can be closed when Plone 4.3 has been released (since it will contain Products.TinyMCE 1.3?

comment:53 Changed 15 months ago by keul

No more opposition about this as Plone 4.3 in near to be released :)

comment:54 Changed 15 months ago by dkozar

  • Status changed from confirmed to closed
  • Resolution set to fixed
  • Milestone changed from 4.x to 4.3

Fixed in Plone 4.3. Feels good to close this one.

Note: See TracTickets for help on using tickets.