Ticket #11840 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 years ago

Too generic Sunburst CSS rules that break margin in portlet

Reported by: keul Owned by:
Priority: minor Milestone: 4.x
Component: Templates/CSS Version: 4.1
Keywords: Cc: keul, nekorin


This CSS rules:

#content dd {
    margin: 0 0 1em 2em;

this is taken from public.css

The problem there is that this rule is too generic. Creating custom views, os using products like collective.portletpage or similar products give you a bad layout, because portlet are done using DD but this rules give a margin also to portlets.

Someway, a lesser specific rules must be given, like:

#content-core dd {
    margin: 0 0 1em 2em;

Change History

comment:2 Changed 3 years ago by maartenkling

No harm to do this.

i made some changes:  https://github.com/plone/plonetheme.sunburst/pull/9

comment:3 Changed 3 years ago by maartenkling

  • Status changed from confirmed to closed
  • Resolution set to fixed


Note: See TracTickets for help on using tickets.