Ticket #12156 (closed Bug: fixed)

Opened 3 years ago

Last modified 2 years ago

Portal footer is double-wrapped in 'row' divs

Reported by: davidjb Owned by: andren
Priority: minor Milestone: 4.x
Component: Templates/CSS Version:
Keywords: Cc:

Description

At present, Plone's portal footer gets double-wrapped in 'row' divs when using the standard Sunburst theme. Line 161-162 in plonetheme/sunburst/skins/sunburst_templates/main_template.pt includes a row, and places the footer inside is thusly:

           <div i18n:domain="plone" tal:condition="not:ajax_load" class="row">
	        <div tal:replace="structure provider:plone.portalfooter" />
                ...

However, the portal footer in plone/app/layout/viewlets/footer.pt also includes a row on the outer-most div in this template. This results in HTML that looks like this:

<div class="row">
        <div class="row">
    <div class="cell width-full position-0">

        <div id="portal-footer">
            <p>
        ...

Should the outer-most div within footer.pt just be the 'cell' div? This would seemingly make it more consistent with the rest of the theme/main_template.

Change History

comment:1 Changed 2 years ago by kleist

Plone version please?

comment:2 Changed 2 years ago by davidjb

Present since plonetheme.sunburst 1.1.5, so Plone 4.1+ are affected by this.

FYI:  https://github.com/plone/plonetheme.sunburst/commit/b32bc537876eb8f23b346c597fd1de42e1a92828

comment:3 Changed 2 years ago by kleist

  • Milestone set to 4.x

comment:4 Changed 2 years ago by andren

  • Status changed from new to assigned
  • Owner set to andren
  • Version set to 4.1

comment:5 Changed 2 years ago by andren

  • Status changed from assigned to confirmed

I fixed that moving .row to main-template like occur in other places (portal-top and portal-columns).

main-template:

    <div i18n:domain="plone" tal:condition="not:ajax_load" id="portal-bottom" class="row">
        <div class="cell width-full position-0">
            <div tal:replace="structure provider:plone.portalfooter" />
            <div id="kss-spinner">
                <img tal:attributes="src string:${portal_url}/spinner.gif" alt="" />
            </div>
        </div>
    </div>

portal.footer:

<div metal:define-macro="portal_footer"
     i18n:domain="plone"
     id="portal-footer">

        <p>
        ...
        </p>

</div>

comment:6 Changed 2 years ago by andren

  • Status changed from confirmed to closed
  • Version 4.1 deleted
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.