Ticket #12184 (closed Bug: wontfix)

Opened 3 years ago

Last modified 14 months ago

plone.app.registry: missing upgrade step 4.0.x - 4.1, 4.1.2

Reported by: AbimAbam Owned by:
Priority: critical Milestone: 4.x
Component: Upgrade/Migration Version: 4.1
Keywords: selection, checkbox, scrollbar, unsupported Cc: cah190

Description (last modified by kleist) (diff)

Migrating from 4.0.x to 4.1 causes following problems:

a) Visual representation of tagging-box isn't correct.

Changed from multisel-box to checkbox-layout but scrollbars are missing causing very large pages if large number of tags is used. Selected list is below instead of right of the multiselect-checkbox-list.. (Changed in 4.1  http://dev.plone.org/plone/ticket/11017)

b) Can't find registry (see below).

Start:

Plone 4.0.9 Zope 2.12.19

Target:

Plone 4.1 Zope 2.13.8 Python 2.6.6 (r266:84292, Dec 26 2010, 22:31:48) [GCC 4.4.5] (Debian)

Migration Output:
Starting the migration from version: 4022
Role / permission map imported.
Archetype tool imported.
Cannot find registry
Ran upgrade step: Miscellaneous
Role / permission map imported.
Archetype tool imported.
Cannot find registry
Converting to IITreeSet for index `object_provides`.
Finished conversion.
Converting to IITreeSet for index `Type`.
Finished conversion.
Converting to IITreeSet for index `id`.
Finished conversion.
Converting to IITreeSet for index `cmf_uid`.
Finished conversion.
Converting to IIBTree for index `end`.
Finished conversion.
Converting index `is_folderish` to BooleanIndex.
Finished conversion.
Converting to IITreeSet for index `getId`.
Finished conversion.
Converting to IIBTree for index `start`.
Finished conversion.
Converting to IITreeSet for index `meta_type`.
Finished conversion.
Converting index `is_default_page` to BooleanIndex.
Finished conversion.
Converting to IIBTree for index `Date`.
Finished conversion.
Converting to IITreeSet for index `review_state`.
Finished conversion.
Converting to IITreeSet for index `portal_type`.
Finished conversion.
Converting to IIBTree for index `expires`.
Finished conversion.
Converting to IITreeSet for index `allowedRolesAndUsers`.
Finished conversion.
Converting to IITreeSet for index `in_reply_to`.
Finished conversion.
Converting index `UID` to UUIDIndex.
Finished conversion.
Converting to IIBTree for index `effective`.
Finished conversion.
Converting to IIBTree for index `created`.
Finished conversion.
Converting to IITreeSet for index `Creator`.
Finished conversion.
Converting to IIBTree for index `modified`.
Finished conversion.
Converting to IITreeSet for index `sortable_title`.
Finished conversion.
Converting to IITreeSet for index `getRawRelatedItems`.
Finished conversion.
Converting to IITreeSet for index `Subject`.
Finished conversion.
Ran upgrade step: Miscellaneous
Role / permission map imported.
Archetype tool imported.
Cannot find registry
Ran upgrade step: Miscellaneous
Role / permission map imported.
Toolset imported.
Archetype tool imported.
Cannot find registry
Ran upgrade step: Miscellaneous
Role / permission map imported.
Archetype tool imported.
Cannot find registry
Optimizing range index `effectiveRange` to respect floor and ceiling dates
Finished range index optimization.
Converting to IITreeSet for index `effectiveRange`.
Converting tree `_since`.
Converting tree `_since_only`.
Converting tree `_until`.
Converting tree `_until_only`.
Finished conversion.
Updating `object_provides` index.
Cleaning up `object_provides` _unindex.
Updated `object_provides` index.
Ran upgrade step: Miscellaneous
Role / permission map imported.
Archetype tool imported.
Cannot find registry
Ran upgrade step: Miscellaneous
Role / permission map imported.
Actions tool imported.
Archetype tool imported.
Cannot find registry
Ran upgrade step: Miscellaneous
Role / permission map imported.
Archetype tool imported.
Cannot find registry
Added missing UUIDs to topic-criteria
Ran upgrade step: Miscellaneous
Role / permission map imported.
Archetype tool imported.
Cannot find registry
Ran upgrade step: Miscellaneous
End of upgrade path, migration has finished
Your Plone instance is now up-to-date.

Change History

comment:1 Changed 3 years ago by kleist

  • Component changed from Unknown to Upgrade/Migration
  • Description modified (diff)

comment:2 Changed 3 years ago by AbimAbam

Is any additional information required/needed?

comment:3 Changed 3 years ago by optilude

See #9472 - seems to be a missing upgrade step

comment:4 Changed 3 years ago by AbimAbam

  • Milestone 4.1 deleted

comment:5 Changed 3 years ago by kleist

  • Milestone set to 4.x

comment:6 Changed 3 years ago by kleist

  • Summary changed from Migration problems from 4.0.x to 4.1 to plone.app.registry: missing upgrade step 4.0.x - 4.1

comment:7 Changed 3 years ago by AbimAbam

  • Summary changed from plone.app.registry: missing upgrade step 4.0.x - 4.1 to plone.app.registry: missing upgrade step 4.0.x - 4.1, 4.1.2

comment:8 Changed 2 years ago by cah190

  • Priority changed from minor to critical
  • Cc cah190 added

After a 3.1.5.1 to 4.1.2 upgrade I can verify that plone.app.registry is not being installed. You can work around this a bit by installing the Add-on "HTTP caching support 1.0" (plone.app.caching) which causes the registry to be created.

However, even with the workaround it appears that plone.app.discussion isn't completely installed (if its installed at all) as there is no Discussion configlet in an upgraded site and the registry seems to be missing the various plone.app.discussion settings. This part can be worked around by using portal_setup to import the "Plone Discussion" profile.

These issues should be addressed in plone.app.upgrade. I'm supposing this missing steps weren't noticed, as most of the early adopters were probably already using plone.app.caching and plone.app.registry in Plone 4.0 instances, as I haven't noticed these issues upgrading from 4.0+plone.app.caching to 4.1.

comment:9 Changed 2 years ago by AbimAbam

Suggested temporary fix for registry problem is working as suggested.

However the display of the tag-list is still not correct. Long list of tags, no scrollbars. Any ideas where to look for the problem?

comment:10 Changed 2 years ago by AbimAbam

Problem a) fixed. was caused by customized public.css-file -> deleted. (in portal_skins/custom)

Problem b) workaround step-by-step:

  • Install  plone.app.caching.
  • In Plone Control-Panel / Add-ons activate the "HTTP Caching support"
  • Update Plone to 4.1.2 / remove plone.app.caching from buildout.cfg
  • Migrate Plone-Site to new version.
  • In portal_setup / Import select Plone Discussions from profile-dropdown. Click "Import all steps" at the bottom

Done. Thank you for your help.

comment:11 Changed 22 months ago by kleist

  • Keywords selection, checkbox, added; selection checkbox migration removed
  • Status changed from new to confirmed
  • Version set to 4.1

Has this been fixed in a later 4.1.x release?

comment:12 Changed 16 months ago by kleist

If this is no longer an issue in Plone 4.2, we could close this ticket when 4.3 is released. Right?

comment:13 Changed 14 months ago by kleist

  • Status changed from confirmed to closed
  • Keywords scrollbar, unsupported added; scrollbar removed
  • Resolution set to wontfix

Closing, since 4.3 is round the corner and then we no longer support 4.1

Note: See TracTickets for help on using tickets.