Ticket #12206 (closed Bug: fixed)

Opened 3 years ago

Last modified 3 years ago

copy-paste of items broken since new release of plone.app.linkintegrity 1.4.3

Reported by: yulka Owned by: witsch
Priority: major Milestone: 4.2
Component: Unknown Version:
Keywords: copy-paste, linkintegrity Cc: __gotcha

Description

Plone4.1 + plone.app.linintegrity 1.4.3: Copy and paste does not do anything (Error: "Paste could not find clipboard content", no error in logs or fg).

Change History

comment:1 Changed 3 years ago by yulka

  • Summary changed from copy-paste broken since new release of plone.app.linkintegrity 1.4.3 to copy-paste of items broken since new release of plone.app.linkintegrity 1.4.3

comment:2 Changed 3 years ago by witsch

  • Status changed from new to closed
  • Resolution set to duplicate

this is a duplicate of #12205, please report further information there...

comment:3 Changed 3 years ago by yulka

This bug does not appear on sites with the previous versions of plone.app.linkintegrity (<1.4.3), while #12205 does.

comment:4 Changed 3 years ago by yulka

  • Status changed from closed to reopened
  • Resolution duplicate deleted

comment:5 Changed 3 years ago by yulka

Another manifestation of probably the same bug was reported in #12203, since both copy-pasting and checking out of a working copy result in the same traseback:

Traceback (innermost last):

    * Module ZPublisher.Publish, line 126, in publish
    * Module ZPublisher.mapply, line 77, in mapply
    * Module ZPublisher.Publish, line 46, in call_object
    * Module OFS.CopySupport, line 233, in manage_pasteObjects
    * Module zope.event, line 23, in notify
    * Module zope.component.event, line 24, in dispatch
    * Module zope.component._api, line 136, in subscribers
    * Module zope.component.registry, line 321, in subscribers
    * Module zope.interface.adapter, line 583, in subscribers
    * Module zope.component.event, line 32, in objectEventNotify
    * Module zope.component._api, line 136, in subscribers
    * Module zope.component.registry, line 321, in subscribers
    * Module zope.interface.adapter, line 583, in subscribers
    * Module plone.app.linkintegrity.handlers, line 73, in modifiedArchetype
    * Module plone.app.linkintegrity.references, line 20, in updateReferences
    * Module Products.Archetypes.Referenceable, line 76, in getRefs
    * Module Products.CMFCore.utils, line 123, in getToolByName

AttributeError: reference_catalog 

comment:6 follow-up: ↓ 7 Changed 3 years ago by gotcha

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.