Ticket #12345 (closed Bug: wontfix)

Opened 2 years ago

Last modified 11 months ago

plone.app.portlets and varnish doesn't play well together

Reported by: toutpt Owned by:
Priority: minor Milestone: 4.x
Component: General Version: 4.1
Keywords: portlet, caching Cc: toutpt@…

Description

I'm faced to an issue with varnish and plone. plone.app.portlets @@toggle-visibility used to hide/show a portlet.

this view is doing it's job and redirect to the referer. The issue is the url is the same, so varnish do not pass the request to the backend, so once I have hide a portlet I can't display it.

I have solved the issue by adding a timestamp:  https://github.com/toutpt/plone.app.portlets/commit/5e147108e1f985e93f29d6f72c6b6a66152f3578

Is this can be solved by changing a configuration of varnish ?

Change History

comment:1 Changed 2 years ago by kleist

  • Component changed from User Experience and Interface to Infrastructure

comment:2 Changed 2 years ago by runyaga

No. What needs to happen is we need a plone.app.esiportlet which can use ESI and varnish can then use that to suck in the portlets.

comment:3 Changed 2 years ago by kleist

  • Milestone set to 4.x

Assuming 4.x

comment:4 Changed 2 years ago by toutpt

I'm not sure this is anything related to ESI. ESI is the solution for rendering portlets in the longterm and has IMO nothing to do with the manage portlets panel.

The best solution should make the response of @@toggle-visibility 'private'. I don't know how to do that with p.app.caching 'way'. I mean if we add a header to the response to write it is private, does p.app.caching will overrite this ?

comment:5 Changed 2 years ago by ldr

Where there are not caching headers, Varnish will use the default ttl. We should just set the appropriate caching headers for the redirect. I fixed this in PAS recently:  http://zope3.pov.lt/trac/changeset/121831/Products.PluggableAuthService/trunk

comment:6 Changed 2 years ago by toutpt

  • Status changed from new to confirmed
  • Version set to 4.1

comment:7 Changed 22 months ago by davisagli

  • Component changed from Infrastructure to General

comment:8 Changed 11 months ago by eleddy

  • Status changed from confirmed to closed
  • Resolution set to wontfix

This ticket has not been modified in over 9 months. In another brazen attempt to clean this tracker up, this is closed. If you really, REALLY care about this ticket, please re-verify that it is still an issue on the current supported releases (4.2 or 4.3) and reopen. Better yet, submit a pull request to fix the bug and then close the bug properly. We <3 you and all of your effort, but we can't go on like this anymore. I hope you aren't too mad and we can still be friends. Hugs.

Note: See TracTickets for help on using tickets.