Ticket #12511 (closed Bug: fixed)

Opened 2 years ago

Last modified 2 years ago

kss devel does not load in google chrome

Reported by: robert@… Owned by: ree
Priority: major Milestone:
Component: KSS (Ajax) Version: 4.1
Keywords: kss google chrome Cc:

Description

the log stubs in /kss/core/kukit/kukit/utils.js crash when the file is loaded in google chrome with an "illegal invocation" error or some such. The reminder of the file is then not loaded and and kss does not work.

The problem is easy to hack. Just catch the error. Stub functions that can be used for logging kukit.logDebug = function(message) {try {kukit._logger.logDebug(message);} catch(e){}}; kukit.log = function(message) {try {kukit._logger.log(message);} catch(e){}};

however a "real" fix would be better. but is bejond my grasp just now.

Change History

comment:1 Changed 2 years ago by ree

  • Status changed from new to assigned

comment:2 Changed 2 years ago by ree

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.