Ticket #12529 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

[plone.formwidget.querystring] querywidget.js loaded for all pages

Reported by: khink Owned by:
Priority: minor Milestone: 4.x
Component: JavaScript Version:
Keywords: plone.app.collection, patch Cc: tisto

Description (last modified by khink) (diff)

querywidget.js is registered for all pages. (This JS calls a view, @@querybuilderjsonconfig, which results in an extra view on Plone being loaded.)

Change History

comment:1 Changed 4 years ago by khink

  • Description modified (diff)
  • Summary changed from [plone.app.collection (master)] querywidget.js loaded for all pages to [plone.formwidget.querystring] querywidget.js loaded for all pages

comment:2 Changed 4 years ago by khink

This may not be a bug. I assumed it was because we got plone.formwidget.querybuilder as a dependency of plone.app.collection (master), but it seems it's also used in tiles. In that case, the JS probably _should_ be registered for any type.

comment:3 Changed 4 years ago by eleddy

  • severity changed from Untriaged to Normal

comment:4 Changed 4 years ago by kleist

  • Status changed from new to confirmed

comment:5 Changed 4 years ago by kleist

  • Milestone set to 4.x

comment:7 Changed 4 years ago by kleist

  • Keywords plone.app.collection, patch added; plone.app.collection removed
  • Component changed from Unknown to JavaScript

comment:8 Changed 4 years ago by kroman0

Also I've fixed this in archetypes.querywidget  https://github.com/plone/archetypes.querywidget/pull/3

comment:9 Changed 4 years ago by kroman0

  • Status changed from confirmed to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.