Ticket #12796 (closed Bug: duplicate)

Opened 2 years ago

Last modified 16 months ago

Sendto - field from: is incorrect

Reported by: irekpias@… Owned by:
Priority: minor Milestone: 4.x
Component: Backend (Python) Version: 4.1
Keywords: tuneup Cc: luke.brannon@…, plone@…

Description

Hi.

We had an upgrade from Plone 3.3.5 to plone 4.1.4. We found thata sendto function from plone was a change. When logged in user use functio sendto - recipient get email not from this user but from user where is configured in plone site: @@mail-controlpanel field from:

In plone 3 it was different. When logged in user send email, then another person recived email from him, not from person, who is configured in @@mail-controlpanel in field from:

Now this behaviour in plone4 confiused our users.

What can we do whit this problem.

Change History

comment:1 Changed 2 years ago by eleddy

  • Keywords tuneup added
  • Status changed from new to confirmed
  • Component changed from Unknown to Backend (Python)

ok translating this a bit. The issue is the send_to form. This is disabled in Plone 4. To get to this form you can go to  http://localhost:8080/Plone/sendto_form . You can put an email address in the From field and if there is a site email configured it will always send from the site address which is a weird user experience. This is the correct behavior because this is how mail gets out through different hosts and past spam protection.

However, people will want to know how to respond so we should set the "from" address in the form as a "reply-to" header. This means the user can then reply to the person who sent the email. This can be done at  https://github.com/plone/Products.CMFPlone/blob/master/Products/CMFPlone/PloneTool.py#L170

If envelope_from is set, then we should take send_from_address and make it the reply too. This is a great ticket for tuneups or people getting into plone dev!

comment:2 follow-up: ↓ 3 Changed 2 years ago by irekpias

So you confirm, that this behaviour of Plone 4 is different from Plone 3 and this is bug ?

I noticed too, when user isn't login in our Plone Intranet site and use this send_to form, he must filled 2 e-mails adresses: from: and to:

Plone 4.1.4 ignores from: field and e-mail is send from plone site administrator.

I have yet additional: In this functionality, at the end of message is sign of user, this is always a site administrator. I'm at stand: this should be name of user, who send this email.

By now this functionality is a some mess, becasue sends some false info to recipient: false from: and false sign at bottom of email.

comment:3 in reply to: ↑ 2 Changed 2 years ago by eleddy

  • Cc luke.brannon@…, plone@… added

Replying to irekpias:

So you confirm, that this behaviour of Plone 4 is different from Plone 3 and this is bug ?

I noticed too, when user isn't login in our Plone Intranet site and use this send_to form, he must filled 2 e-mails adresses: from: and to:

This is different, but in a different way. The behavior of "From" is correct. This is anti-spam measure plus site policy. I verified with several large site admins that this is correct. However, it IS ignoring the from field, and that should be set as the reply-to. This is a template modification that was actually already fixed but then accidentally deleted. If you are passionate about seeing it fixed, please ping luke.brannon and or mike cullerton.

Plone 4.1.4 ignores from: field and e-mail is send from plone site administrator.

I have yet additional: In this functionality, at the end of message is sign of user, this is always a site administrator. I'm at stand: this should be name of user, who send this email.

By now this functionality is a some mess, becasue sends some false info to recipient: false from: and false sign at bottom of email.

This form is officially deprecated in Plone 4 so I don't think it's surprising that "it's a mess". It requires a customization to make it visible. If this is a separate bug, please open another ticket so we can track it more accurately. Be sure to include expected and actual behaviors.

comment:4 Changed 16 months ago by irekpias

Any info about this issue ? Can be it done ? From field is from user, who send info about article in plone and that user is logged in.

comment:5 Changed 16 months ago by kleist

  • Status changed from confirmed to closed
  • Resolution set to duplicate

duplicate of #12413 (upstreams Zope feature)

Note: See TracTickets for help on using tickets.