Ticket #12995 (closed Feature Request: fixed)

Opened 22 months ago

Last modified 22 months ago

@@sunburstview should generate css classes for column-one/two

Reported by: saily Owned by: saily
Priority: minor Milestone: 4.x
Component: Templates/CSS Version: 4.3
Keywords: Cc:

Description

plonetheme.sunburst has a view which generates css code for portal-column-content only. if you want to customize that behavior, you have to override sunburstview for your theme and customize main_template in a skin folder, because portal-column-one and portal-column-two classes are fixed to 1:4 with.

TODO:

  • remove fixed 'width-1:4' from main_template in plonetheme.sunburst skin folder replace it with (just examples) view/getFirstColumnClass(view) and view/getSecondColumnClass(view)
  • add two new methods to sunburstview which generate these css classnames

If somebody wants to use a own theme based on sunburst he could customize the view for his themelayer only and does not have to register a skin folder any more.

Change History

comment:1 Changed 22 months ago by saily

  • Type changed from Bug to Feature Request
  • Component changed from Unknown to Templates/CSS

comment:3 Changed 22 months ago by saily

  • Owner set to saily
  • Status changed from confirmed to assigned

comment:4 Changed 22 months ago by saily

  • Status changed from assigned to confirmed

comment:5 Changed 22 months ago by saily

  • Status changed from confirmed to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.