Ticket #4300 (closed Bug: fixed)

Opened 9 years ago

Last modified 5 years ago

Using the "display" menu and other content-menu actions during content creation

Reported by: Anonymous User Owned by:
Priority: minor Milestone: 2.1
Component: Templates/CSS Version:
Keywords: Cc:

Description

When you add a folder, and then on the initial screen (where it prompts you for a title etc) you then select display as photo album, you get an error page with 'Index out of range'. I assume this happens because it's trying to perform the function on the portal_catalog.

Change History

comment:1 Changed 9 years ago by alecm

The issue is that you are trying to set this property on an object that doesn't really exist because it is in the portal_factory. Not sure what can be done here short of disabling these menus when in the portal factory. Is there a reason to show the EditableBorder at all when we are in portal_factory? None of those tabs or actions are really maningful in a portal_factory context, are they?

comment:2 Changed 9 years ago by geoff

Not showing the editable border is a good idea. Alternatively, you could make sure that all the functions associated with the tabs call portal_factory's create function before they do their thing.

comment:3 Changed 9 years ago by Anonymous User

I think that removing the editable border will confuse the user, so maybe make the tabs do factory create before affecting the object.

comment:4 Changed 9 years ago by optilude

Please supply a title when you create an issue. :)

+1 for greying out the menu; it makes sense that you should create the item properly before messing with workflow states, layout templates etc.

comment:5 Changed 9 years ago by sparcd

As the original poster for this bug I apologise for the lack of title. However, I was logged in when I posted it, so I was surprised to see Anonymous user as the submitter.

I think that greying out the controls would be a good way to proceed!

comment:6 Changed 9 years ago by optilude

Okay, if this is easily doable, getting it into 2.1 would be nice, esp. as with the increased use of the content menu, the temptation to use it during editing would be higher; if it's non-trivial, we should aim for 2.1.x imho.

comment:7 Changed 9 years ago by optilude

Okay, the consensus here seems to be:

PLIP 24 (form unload protection/warnings) takes care of the default case when someone goes to the 'edit' or 'properties' page and then uses the menu; they'll get warned that they'll lose their changes, and if they know what they're doing, letting them use the 'display' menu etc. would seem to be ok.

However, the menu needs to be disabled when the object is in the portal_factory, because the behaviour of the various items are not well-defined in this case and can cause ugly error messages and generally confusing behaviour. Unload protection still applies, but if the user chooses to ignore it, they'll still get errors; Also, if he/she hasn't made any changes, they won't even get the unload message.

I'll see what I can do about this if there are no other takers.

comment:8 Changed 9 years ago by optilude

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 2.1 svn; the menu is now disabled when you're editing and object in the factory.

comment:9 Changed 5 years ago by hannosch

  • Component changed from Usability to Templates/CSS
Note: See TracTickets for help on using tickets.