Ticket #4313 (closed Bug: fixed)

Opened 9 years ago

Last modified 5 years ago

Focus in search textbox and Internet Explorer

Reported by: harrison Owned by:
Priority: minor Milestone: 2.1.3
Component: Templates/CSS Version:
Keywords: Cc:

Description (last modified by hannosch) (diff)

The search box does not get focus with Internet Explorer if the user clicks on the extreme left part of the textfield. They must click a small distance to the right of the left border.

This is a fully patched Internet Explorer 6.0 under Windoze XP. Plone is running on a RedHat Enterprise server. I see no such problems with Mozilla under Windoze or Linux.

Although I'm fairly new to administering Plone, I don't think I did anything to cause this. The site is pretty much "plain vanilla." I also searched this list and couldn't find any report of this behavior, which surprised me.

-- David Harrison, Dept. of Physics, Univ. of Toronto

Attachments

search focus.JPG Download (91.5 KB) - added by MikeZ(mreitsma@… 8 years ago.
Shows with blue border the width of H1 tag obscuring the search box

Change History

comment:1 Changed 9 years ago by limi

I believe this has been fixed in Plone 2.1, but it needs to be verified.

comment:2 Changed 9 years ago by hannosch

  • Status changed from new to closed
  • Resolution set to fixed

This has been fixed in Plone 2.1. At least I can't reproduce it anymore.

comment:3 Changed 8 years ago by sluxford

The error is currently occurring on www.litig.org. The only way to enter text in the searchbox is to click on the page and then use the tab key to move into the searchbox. The site is currently running Plone 2.1 on Zope 2.8.1.

Will test upgrading to Plone 2.1.2 to see if it solves the problem.

Searchbox works fine in FireFox - its only IE that appears to have the problem.

comment:4 Changed 8 years ago by MikeZ (mreitsma@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

This is still a problem in IE and Plone 2.1.2. The Search box is obscured by the H1 #portal-logo that holds the Plone logo. If you use MS IE Developers Toolbar you can see that. Fixing it means giving the H1 a fixed width (you might not want that...) or giving it a display: inline instead of display: block. Problem is that this shifts the H1 and logo upwards. You're better of with an H1 width:1% if you can apply this to IE only. FF et al. minimize the picture then

Changed 8 years ago by MikeZ(mreitsma@…

Shows with blue border the width of H1 tag obscuring the search box

comment:5 Changed 8 years ago by hannosch

  • Component changed from Usability/Accessibility to Visual and templates
  • Description modified (diff)
  • Milestone changed from 2.1 to 2.1.x

comment:6 Changed 8 years ago by hannosch

  • Status changed from reopened to closed
  • Resolution set to fixed

(In [9715]) Merged changes from waldru-fixes branch:

  • Repaired the portal logo appearance visual bug in IE 5, 5.5. This closes #5228.
  • Corrected the portlet_calendar view for tableless layout for Firefox. This closes #5467.
  • When setting some background to the top, Live Search did not look properly. Moreover in IE it had a bad visual behavior. Changed the visual representation of the Live Search to repair the improper look. This closes #4313 and #5005.
  • contentActions drop down menus were falling below the content area text in IE. This closes #4949, #4960 and #4961.

comment:7 Changed 8 years ago by hannosch

  • Milestone changed from 2.5.x to 2.1.3

comment:8 Changed 5 years ago by hannosch

  • Component changed from Visual and templates to Templates/CSS
Note: See TracTickets for help on using tickets.