Ticket #4372 (closed Bug: fixed)

Opened 9 years ago

Last modified 5 years ago

proposal: disable " Warnning when Leave Page" in common view view

Reported by: Anonymous User Owned by:
Priority: minor Milestone: 2.1
Component: Templates/CSS Version:
Keywords: Cc:

Description

It's reaaly painful be asked to confirm very time when leave from a common view page, When a average user access this site, how confuse with the endless popup confirm window ?

how about disable it in a common view page, and enable it in a _edit view ?

Change History

comment:1 Changed 9 years ago by shh

Please report only ONE bug per collector entry! Thanks.

comment:2 Changed 9 years ago by shh

And of course the pop-up should only fire on edit forms *and* only if changes have been made. I am suprised you see this on "view" templates at all.

comment:3 Changed 9 years ago by elvix

well. you cannot really know what page is an edit form from its path. Checking the id for *_edit sounds like a dog-ugly hack to me.

It is supposed to only fire on forms, and only when they have been changed after loading. To remove the behavior, disable that one script in portal_javasctripts.

Anyway. this has been discussed on the development list. as far as i remember, Duncan was planning to change the behavior to be turned on explicitly per-form, instead of being on everywhere by default. Move the discussion to plone-dev.

Unless there is some confirmation that the behavior triggers on non-forms or on forms that have not been changed, this is not a bug and should be rejected.

comment:4 Changed 9 years ago by geoff

If there's going to be any move to per-form invocation (and there definitely should be), it needs to happen TODAY (Friday, Aug 5) or TOMORROW. That's a change that will affect a bunch of files, and it needs to happen before the next RC.

comment:5 Changed 9 years ago by alecm

I have not seen the form unload alert on anything other than a form for some time.b The fix that required explicit enabling on each form was done here:  http://svn.plone.org/view/plone?rev=7340&view=rev

Unless the original author can report some steps to reproduce, this issue should be closed.

comment:6 Changed 9 years ago by alecm

  • Status changed from new to closed
  • Resolution set to fixed

It turns out to be due to a bug in the Firefox deerpark alpha. Thanks to jenner for digging through this and making a patch. Fix committed to svn.

comment:7 Changed 5 years ago by hannosch

  • Component changed from Accessibility to Templates/CSS
Note: See TracTickets for help on using tickets.