Ticket #4646 (closed Bug: fixed)

Opened 9 years ago

pywintypes23.dll Error with source install/existing Zope installation

Reported by: hillsy Owned by:
Priority: minor Milestone: Past
Component: General Version:
Keywords: Cc:

Description

I think this is a dupe of #4427, or at least related. But when I tried to post to that entry I got back an "insufficient privileges" error. So I'll put my experiences into a new issue, sorry.

I have what looks to be a similar error. Win2k3 Zope 2.7.6 (legacy install for 2.0.5 sites currently on the machine) Zope 2.7.7 (from Zope.org) Plone 2.1-rc3 (source tarball) Location of python.exe has been manually entered into the system path (D:\Program Files\Zope\2.7.6\bin in our case) Python has been registered using  http://effbot.org/zone/python-register.htm - this is for an LDAP module that uses distutils.

When starting Zope 2.7.7 using runzope.bat, I get the attached error. Clicking OK allows Zope to start normally. Also installing it as a service and starting the service seems to work OK.

A Google led to an extensive thread on zope-dev which seemed to discuss this WRT Zope 2.8:  http://www.mail-archive.com/zope-dev@zope.org/msg18391.html Also:  http://mail.python.org/pipermail/python-list/2005-January/263416.html

On the assumption it was loading the wrong DLL, I tried copying the pywintypes23.dll from Zope 2.7.7 to Zope 2.7.6, at which point Zope crashed with the PySECURITY_ATTRIBUTES error.

Change History

comment:1 Changed 9 years ago by hillsy

Hmmm. Adding the new (2.7.7) python bin path *ahead* of the legacy (2.7.6) bin in the system path appears to have resolved the issue i.e. D:\Program Files\Zope\2.7.7\bin;D:\Program Files\Zope\2.7.6\bin;

I don't know if this is a fix, but it's a workaround.

comment:2 Changed 9 years ago by hillsy

More hmmm. Zope 2.8.1 fails completely with the following traceback:

Traceback (most recent call last):

File "D:\Program Files\Zope\2.8.1\lib\python\Zope2\Startup\run.py", line 56, i

n ?

run()

File "D:\Program Files\Zope\2.8.1\lib\python\Zope2\Startup\run.py", line 21, i

n run

starter.prepare()

File "D:\Program Files\Zope\2.8.1\lib\python\Zope2\Startup\init.py", line

99, in prepare

self.registerSignals()

File "D:\Program Files\Zope\2.8.1\lib\python\Zope2\Startup\init.py", line

320, in registerSignals

Signals.registerZopeSignals([self.cfg.eventlog,

File "D:\Program Files\Zope\2.8.1\lib\python\Signals\Signals.py", line 116, in

registerZopeSignals

SignalHandler.registerHandler(SIGTERM, shutdownFastHandler)

File "D:\Program Files\Zope\2.8.1\lib\python\Signals\WinSignalHandler.py", lin

e 208, in registerHandler

hevent = win32event.CreateEvent(sa, 0, 0, event_name)

TypeError: The object is not a PySECURITY_ATTRIBUTES object

So I can get 2.7.6 and 2.7.7 to coexist by putting both in the path, but not 2.8.1. This is a bit problematic because we'd like to run 2.8 for new sites, but have to keep 2.7 around for sites currently running 2.0.5

comment:3 Changed 8 years ago by hannosch

  • Status changed from new to closed
  • Resolution set to fixed

A new build of pywintypes (205) which is part of Zope 2.8.4 should resolve this problem.

comment:4 Changed 22 months ago by davisagli

  • Component changed from Infrastructure to General
Note: See TracTickets for help on using tickets.