Ticket #7300 (closed Bug: fixed)

Opened 6 years ago

Last modified 6 years ago

Limiting the number of versions is not working

Reported by: sebas Owned by: alecm
Priority: major Milestone: 3.0.4
Component: Versioning Version:
Keywords: Cc:

Description

Plone 3.0.2 rev2 unified installer. Just set the maximum number of versions to keep in the storage by using the corresponding property of portal_purgepolicy. Now create a new page and modify it until reaching the maximum number of versions. Then you cannot update the page never more (using Kupu or the plain html editor). Surprisingly you can use the "save" button on the kupu menu and after that cancel the edition. This updates the last version but it doesn't shift the versions list. Everytime that you try to unsuccesfully save the modified page, a new error is filed in the log. I attach one of these.

Attachments

error.txt Download (4.9 KB) - added by sebas 6 years ago.

Change History

Changed 6 years ago by sebas

comment:1 Changed 6 years ago by sebas

  • Priority changed from critical to major

It seems to me that the problem is located in the call to storage.purge here /CMFEditions/trunk/KeepLastNVersionsTool.py?rev=53357#L89

This call have 5 actual parameters. However the method purge expects only 4 arguments according to the interface. If the argument 'comment' is deleted, the error disapears.

I don't know whether the comment should be part of the metadata.

comment:2 Changed 6 years ago by alecm

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in svn r54488

Note: See TracTickets for help on using tickets.