Ticket #7425 (closed Bug: fixed)

Opened 6 years ago

Last modified 5 years ago

/@@mail-controlpanel | Mail server and Mail sender | click Save | review of the panel re-presents the _previous_ entries

Reported by: grahamperrin Owned by:
Priority: minor Milestone: 3.1.5
Component: General Version:
Keywords: Cc: grahamperrin

Description

After a Data.fs was received by us, from a developer, it was necessary for me to change the SMTP server address and port, and the sender's e-mail address.

My routine was

/@@mail-controlpanel
| Mail server | change the smtp server address and port | Mail sender | change the Site 'From' address | single-click Save | observe the confirmation message.

To check that my changes to both tabs of the Mail control panel had been changed: after observing the confirmation message, I loaded a different control panel then returned to Mail.

The first thing I noticed was that my changes to address and port number under Mail server apparently were not saved. The previous entries were re-presented to me.

I made both changes again (server address and port) then clicked Save, without progressing to Mail sender.

Loaded a different control panel, returned to Mail, satisfied myself that both changes under Mail server were saved successfully. OK this time.

Progressed to Mail sender, found that my change to the sender's address apparently was not saved. As with the other tab, under the Mail sender tab the previous entry was re-presented to me. I re-entered the change, clicked Save.

A subsequent review of the panel and its two tabs suggests that the changes are now properly saved.


It may be that this is a bug with presentation of the entries, I wonder whether my changes to both tabs were indeed saved when I first clicked the Save button, wonder whether subsequent visits to the Mail control panel and tabs presented cached data or something like that.

On the assumption that it's a presentation issue, I'm starting this at minor priority; but if it's reproducible, and turns out to be a Save issue, it might benefit from higher priority.

Thanks Graham

Change History

comment:1 Changed 6 years ago by grahamperrin

See also #7694

comment:2 Changed 6 years ago by hannosch

  • Status changed from new to closed
  • Resolution set to fixed

(In [21525]) Simplified the mail control panel to present all information on one tab. In case of validation errors the panel behaved in most unintuitive ways. This closes #7425, #7694 and #6916.

comment:3 Changed 5 years ago by hannosch

  • Component changed from Control Panel to Infrastructure

comment:14 Changed 22 months ago by davisagli

  • Component changed from Infrastructure to General
Note: See TracTickets for help on using tickets.