Ticket #7494 (closed Bug: fixed)

Opened 6 years ago

Last modified 6 years ago

Insert internal link using IE links in the wrong place

Reported by: hidrogen123 Owned by: duncan
Priority: major Milestone: 3.0.6
Component: Visual Editor Version:
Keywords: kupu, IE Cc:

Description

In Internet Explorer 7, when I try to insert an internal link the link shows up in a header I have on top of the page.

Attachments

internlinkdrawer_ie6.png Download (11.9 KB) - added by localhost 6 years ago.
Internal Link drawer in IE6
internallinkdrawer_ff2.png Download (40.7 KB) - added by localhost 6 years ago.
Internal Link drawer in Ff2

Change History

comment:1 Changed 6 years ago by duncan

Which version of kupu?

comment:2 Changed 6 years ago by hidrogen123

Kupu 1.4.6 and Plone 3.0.4

comment:3 Changed 6 years ago by localhost

  • Priority changed from minor to major
  • Keywords kupu, IE added

I can confirm this for IE6 and IE7 for Plone 3.0.4 running under Linux and running under Windows 2k3 Server. This is a problem in at least kupu 1.4.6 and 1.4.7. As far as I can tell I can't reproduce this with Firefox.

There is a, perhaps, important difference between the interal link drawer in IE and in Ff. If you select text, then hit the interal link button, browse to the page you want to link and select the radiofield some new information is shown on the right. In Ff you only get a dropdown to select 'top of page' and any available anchors. In IE there is a sectionfield and the dropdown. The selectionfield is by default not selected!

I've noticed there is a work around for IE:

  • Edit your page.
  • Select your text.
  • Hit the insert internal link icon.
  • Browse to the item you want, select the radiofield in front.
  • Enable the 'Link to anchor' selectionfield.
  • Hit the dropdown and select 'top of page'. (This seems to be the default action, but it is NOT selected!)
  • Hit ok.

The link should be placed correctly now.

Is this issue perhaps related to issue 7377 Making an Image a Link within Kupu renders the link tag at the top of the content page?

Changed 6 years ago by localhost

Internal Link drawer in IE6

Changed 6 years ago by localhost

Internal Link drawer in Ff2

comment:4 Changed 6 years ago by elvix

We have customers reporting the same problem. Kupu 1.4.7 Internet Explorer 7, Version 7.0.5730.11

comment:5 Changed 6 years ago by jvloothuis

What seems to happen is that when you click on anything other than the radio button's circle IE loses the current selection. So if you click the radio when selecting a document then everything is fine. If you click the link then the problem occurs.

comment:6 Changed 6 years ago by duncan

  • Status changed from new to closed
  • Resolution set to fixed

Thank you, that was what I needed to know.

The problem was that in IE (which only has one 'current selection') we have to save the selection every time it changes, and putting the focus back into the iframe was enough to trigger the selection saving code again before the original had been restored.

Fixed in SVN revision 51164

Note: See TracTickets for help on using tickets.