Ticket #8115 (closed Feature Request: wontfix)

Opened 6 years ago

Last modified 11 months ago

Create configuration registry record for batch size in search results and folder contents

Reported by: WouterVH Owned by: WouterVH
Priority: minor Milestone: 4.x
Component: Templates/CSS Version: 4.1
Keywords: discuss Cc: grahamperrin, incunabulum, pelle, spereverde

Description (last modified by dukebody) (diff)

The number of items shown by default in the foldercontents is hardcoded in a BrowserView: tableview.py.

Although I think it's a good default, I find it frustratingly small for some of my websites. I would suggest to move this value to a new property in site_properties.

Change History

comment:1 Changed 6 years ago by grahamperrin

  • Cc grahamperrin added

comment:2 Changed 6 years ago by hannosch

  • Milestone changed from 3.x to Future

Sounds like a good idea to me. If someone wants to provide a patch for it :)

comment:3 Changed 5 years ago by hannosch

  • Component changed from Usability to Templates/CSS

comment:4 Changed 4 years ago by dukebody

  • Status changed from new to assigned
  • Owner changed from limi to dukebody
  • Description modified (diff)

comment:5 Changed 4 years ago by dukebody

  • Status changed from assigned to closed
  • Resolution set to fixed

There's a "Show all" button introduced in r19669, so let's consider this fixed for now.

comment:6 Changed 4 years ago by hannosch

  • Milestone changed from Future to 4.0

comment:7 Changed 4 years ago by khink

  • Status changed from closed to reopened
  • Resolution fixed deleted

There still is no site property for batch size; we just have a workaround in the "Show all" button. I think we should either change the title of this issue (to "Allow unbatched listing of folder contents" or something like that), or leave it open.

Issue #11201 which i've just opened is related; it's about having a site property "batch size" which is used in search results as well.

comment:8 Changed 3 years ago by calvinhp

  • Keywords discuss added
  • Milestone changed from 4.0 to 4.x

comment:9 Changed 3 years ago by incunabulum

Some setting regarding batch size is not only required for the folderview implementation (where we have a "Show All" button) but also for e.g. for the thumbnail_view (were we have no "Show All" button). Therefore,making this configurable woould be great...

Any progress on this issue?

comment:10 Changed 3 years ago by incunabulum

  • Cc incunabulum added

subscribe

comment:11 Changed 3 years ago by dukebody

  • Status changed from reopened to new
  • Owner dukebody deleted

I'm no longer working on this, sorry. But I agree on that there should be a configurable property.

comment:12 Changed 3 years ago by WouterVH

  • Owner set to WouterVH
  • Status changed from new to assigned

comment:13 Changed 3 years ago by pelle

  • Cc pelle added

comment:14 Changed 3 years ago by kleist

Agreed: the current default batch size (20) is ridiculously low, given today's speed of Internet and web browsers.

Oddly enough, when I changed 20 to 100 in the .pt, I got an exception... I didn't spend much time with it, but maybe this "20" is hardcoded also elsewhere?!

comment:15 Changed 3 years ago by hannosch

Actually 20 isn't low at all. We just changed the search result pages to a 10 items batch size, as you are used from any public internet search engine.

For folder listings it makes sense to show a bit more, but generally the results should more or less fit in the browser without introducing any or much scrolling. In many cases you are only interested in the first entries of the listing, if for example they are sorted by date.

The lower the batch size is, the faster it is to render and transmit the page, resulting in a much better user experience. The trick is to have the pages render so fast, that moving to the second page feels almost instant. You cannot get that if each batch page shows 100 items or more.

There are listing for which it makes sense to show more items, especially if there's not much information shown per item and the display is quite dense, like a tabular view.

But 20 items is still a very reasonable default.

All that said, moving the batch size to a configurable property shouldn't introduce too much overhead.

comment:16 Changed 3 years ago by kleist

What you say does make sense, I withdraw my case. (Except for "folder_contents", where this low default makes it really boring to move stuff in a folder with many items... )

comment:17 Changed 2 years ago by spereverde

  • Status changed from assigned to confirmed
  • Version set to 4.1

related to (duplicate of?) #11201 this has been a ticket in our own trac for a while now, so +1

comment:18 Changed 2 years ago by spereverde

  • Cc spereverde added

comment:19 Changed 22 months ago by kleist

  • Summary changed from Move hardcoded batchsize to site_property to Create configuration registry record for batch size in search results and folder contents

Closed #11201 as a duplicate of this one.

And I think we all agree that what we need is a configuration registry record, not a new property in site_properties.

comment:20 Changed 11 months ago by eleddy

  • Status changed from confirmed to closed
  • Resolution set to wontfix

This ticket has not been modified in over 9 months. In another brazen attempt to clean this tracker up, this is closed. If you really, REALLY care about this ticket, please re-verify that it is still an issue on the current supported releases (4.2 or 4.3) and reopen. Better yet, submit a pull request to fix the bug and then close the bug properly. We <3 you and all of your effort, but we can't go on like this anymore. I hope you aren't too mad and we can still be friends. Hugs.

Note: See TracTickets for help on using tickets.