Ticket #8150 (closed Bug: wontfix)

Opened 8 years ago

Last modified 6 years ago

Special characters from text file cause unexpected spacing in Win98 / Firefox

Reported by: vedawms Owned by: duncan
Priority: major Milestone: 3.3.5
Component: Visual Editor Version:
Keywords: Cc:


Using: Plone 2.5.5, kupu 1.4.2.

The attached file was cleaned up by a client using Win98 and Wordpad. I opened it on my Mac using TextEdit, and see no special characters. Similarly, opening the file in TextMate on my Mac does not show any special characters.

But, if I take the same file and go to my PC (Windows XP) and open it in Notepad, I see special characters in the file indicating where <br> or <p> tags would ordinarily be.

Using Firefox for OS X 10.4.11, if I select everything and cut and paste it, there are some unexpected spaces that also get added. I am able to edit these spaces out in Firefox, and saving preserves this. (I can't test on Safari, as this is before kupu played well with Safari.)

On the PC, I'm able to paste everything into Firefox without issue, no extra spaces, no cleanup needed.

However, my client, running Windows 98, Firefox, IE7, Wordpad, and Notepad, is getting the extra spacing using both kinds of browsers and both text editors. She has to edit each page twice to get the styling to take. I'm guessing the problem is either Windows 98 or that her text editor has some sort of different encoding / character set on it than mine?

What should her character set be set to, and where can this be be set? Or, is there another solution you can think of?


  • Veda


press release example_notepad-1.txt Download (8.2 KB) - added by vedawms 8 years ago.
file from client, cleaned up and ready for pasting / formatting in kupu

Change History

Changed 8 years ago by vedawms

file from client, cleaned up and ready for pasting / formatting in kupu

comment:1 Changed 8 years ago by duncan

The file attachment is in UTF16LE encoding.

One of the problems with Windows 98 was that it only had limited unicode support. My guess therefore would be that the problem is with Windows 98 and the only solution may be to use a different system.

comment:2 Changed 8 years ago by vedawms

Understood. Feel free to close this bug then. Thanks!

comment:3 Changed 6 years ago by jonstahl

  • Status changed from new to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.