Ticket #8159 (closed Bug: fixed)

Opened 6 years ago

Last modified 5 years ago

Subtopics are not displayed correctly

Reported by: naro Owned by: alecm
Priority: major Milestone: 3.1.2
Component: General Version:
Keywords: Cc:

Description

  • create fresh Plone site (tested on 3.1 branch)
  • click on Events
  • create event starting-ending in the future and publish it (without effective date set)
  • click on Events link again (to display all events)

Event is displayed both in active and contained events. That is wrong.

Attachments

FirefoxScreenSnapz004.jpg Download (27.1 KB) - added by naro 6 years ago.
Example

Change History

Changed 6 years ago by naro

Example

comment:1 Changed 6 years ago by naro

#8163 set as duplicate of this bug.

comment:2 Changed 6 years ago by sergey_v

Since my ticket was closed (sorry for duplicate), I'll post the fix here so it won't be overlooked

Actually the things are going in the following order:

  1. CMFPlone's folder_summary_view calls here/atct_topic_view/macros/folderlisting_macro
  1. ATCT's folderlisting_macro calls here/base/macros/folderlisting. Also it defines folderListing as here/getFolderListing
  1. Archetypes' folderlisting macro calls here/folder_listing/macros/listing
  1. CMFPlone's folder_listing displays the actual listing (aren't there too many levels of indirection, huh?). It never checks folderListing variable set at step 2 and instead makes its own call to either getFolderContents or queryCatalog.

So the fix seems to be as follows (folder_listing.pt, line 47):

folderContents folderContents|nothing; folderContents python:folderContents or is_a_topic and here.queryCatalog(contentFilter) or here.getFolderContents(contentFilter, batch=True, b_size=limit_display or 100);

comment:3 Changed 6 years ago by seletz

  • Status changed from new to closed
  • Resolution set to fixed

Applied fix in r21001

comment:4 Changed 5 years ago by hannosch

  • Milestone changed from 3.1.3 to 3.1.2

comment:5 Changed 5 years ago by hannosch

  • Component changed from Content Types to Infrastructure

comment:6 Changed 22 months ago by davisagli

  • Component changed from Infrastructure to General
Note: See TracTickets for help on using tickets.