Ticket #8307 (closed Bug: fixed)

Opened 7 years ago

Last modified 6 years ago

ComponentLookupError at Language of Site Setup

Reported by: tyam Owned by: witsch
Priority: major Milestone: 3.3
Component: General Version:
Keywords: Cc:

Description

I have installed Plone 3.1.3 with Windows installer (including everything) on My Japanese version of Windows Vista Business, ThinkPad X60 3GB. I have started Plone with Plone Controller and logged in with administrator account. Then I have clicked "Site Setup" and then "Language". I have got a following message.

We're sorry, but there seems to be an error… Since you are a site administrator, you can see the full error message

I found this error is not only for Language item, but for many other items of Site Setup. I could see the same message when I clicked other items, eg. calendar, HTML-filtering, Mail, Maintanence, Markup, Search, Security, Site, Theme, Users and Groups. Other items does not have this problem. I have clicked the full error message link and obtained a full text which is attached.

Attachments

cperrorlog.txt Download (7.9 KB) - added by tyam 7 years ago.
full text of error log

Change History

Changed 7 years ago by tyam

full text of error log

comment:1 Changed 7 years ago by hannosch

  • Owner changed from hannosch to witsch
  • Component changed from Control Panel to Infrastructure

This looks like there is a problem with the CSRF protection, which uses the IKeyManager utility.

comment:2 Changed 7 years ago by tyam

This same error occurs with Plone 3.1.4 as well on same hw and OS. Following is from event.log file. ========================================================

Module zope.tal.talinterpreter, line 346, in interpret Module zope.tal.talinterpreter, line 534, in do_optTag_tal Module zope.tal.talinterpreter, line 516, in no_tag Module zope.tal.talinterpreter, line 346, in interpret Module zope.tal.talinterpreter, line 745, in do_insertStructure_tal Module Products.PageTemplates.Expressions, line 221, in evaluateStructure Module zope.tales.tales, line 696, in evaluate

  • URL: control-panel
  • Line 191, Column 16
  • Expression: <PathExpr standard:'context/@@authenticator/authenticator'>
  • Names:

{'container': <PloneSite at /Plone>,

'context': <PloneSite at /Plone>, 'default': <object object at 0x00F2C528>, 'here': <PloneSite at /Plone>, 'loop': {}, 'nothing': None, 'options': {'args': ()}, 'repeat': <Products.PageTemplates.Expressions.SafeMapping object at 0x072BBA58>, 'request': <HTTPRequest, URL= http://localhost:8080/Plone/@@language-controlpanel>, 'root': <Application at >, 'template': <ImplicitAcquirerWrapper object at 0x07ABFDF0>, 'traverse_subpath': [], 'user': <PropertiedUser 'admin'>, 'view': <Products.Five.metaclass.LanguageControlPanel object at 0x07AF3F30>, 'views': <zope.app.pagetemplate.viewpagetemplatefile.ViewMapper object at 0x07AED3B0>}

Module zope.tales.expressions, line 217, in call Module Products.PageTemplates.Expressions, line 161, in _eval Module Products.PageTemplates.Expressions, line 123, in render Module plone.protect.authenticator, line 45, in authenticator Module zope.component._api, line 207, in getUtility

ComponentLookupError: (<InterfaceClass plone.keyring.interfaces.IKeyManager>, )

comment:3 Changed 7 years ago by tyam

When I saw the source code, plone.keyring package is located under Plone 3/Python/Lib/site-packages as an egg. There is a configure.zcml and it says, <configure

xmlns=" http://namespaces.zope.org/zope" xmlns:zcml="http://namespaces.zope.org/zcml" xmlns:genericsetup="http://namespaces.zope.org/genericsetup" i18n_domain="plone.keyring">

Does the i18n_domain works fine?

I saw the Product Mangement list with control panel through ZMI and I found there is no keyring product installed.

I hope this could be helpful to solve this problem.

comment:4 Changed 7 years ago by tyam

I have tried to make debug-mode on by changing etc/zope.conf, but I could not make it, due to access isdenied. I found that Windows Vista has different security machinery from XP. Following document describes about virtualization of HKEY_LOCAL_MACHINE on page 17 of the following document.  http://www.microsoft.com/downloads/details.aspx?FamilyID=BA73B169-A648-49AF-BC5E-A2EEBB74C16B&displaylang=en

Hoping this could be helpful to fix this problem, too.

comment:5 Changed 7 years ago by tyam

  • Status changed from new to closed
  • Resolution set to fixed

Finally, I found the reason. This problem is solved. I happened to find the portal migration was not made when I installed the newer version of Plone. I went to ZMI and cliked portal migration, and found my site is 3.0.5 though the Plone software was 3.1.4. I clicked "update" and the symptom has disappeard. tyam.

comment:6 Changed 6 years ago by hannosch

  • Milestone changed from 3.x to 3.3

comment:7 Changed 3 years ago by davisagli

  • Component changed from Infrastructure to General
Note: See TracTickets for help on using tickets.