Ticket #8380 (closed Bug: fixed)

Opened 6 years ago

Last modified 4 years ago

GS import of Navigation portlet fails

Reported by: tom_gross Owned by: amleczko
Priority: major Milestone: 3.3.5
Component: General Version:
Keywords: naviagtion portlet genericsetup vocabulary TuneUp17 forqa Cc:

Description

Importing a GS-profile of the navigation-portlet with an empty "root" property fails with:

Traceback (innermost last):
  Module ZPublisher.Publish, line 119, in publish
  Module ZPublisher.mapply, line 88, in mapply
  Module ZPublisher.Publish, line 42, in call_object
  Module Products.GenericSetup.tool, line 637, in manage_importTarball
  Module Products.GenericSetup.tool, line 390, in runAllImportStepsFromProfile
  Module Products.GenericSetup.tool, line 1182, in _runImportStepsFromContext
  Module Products.GenericSetup.tool, line 1093, in _doRunImportStep
   - __traceback_info__: portlets
  Module plone.app.portlets.exportimport.portlets, line 707, in importPortlets
  Module Products.GenericSetup.utils, line 544, in _importBody
  Module plone.app.portlets.exportimport.portlets, line 205, in _importNode
  Module plone.app.portlets.exportimport.portlets, line 214, in _initProvider
  Module plone.app.portlets.exportimport.portlets, line 277, in _initPortlets
  Module plone.app.portlets.exportimport.portlets, line 439, in _initAssignmentNode
  Module plone.app.portlets.exportimport.portlets, line 82, in import_assignment
  Module plone.app.portlets.exportimport.portlets, line 126, in import_node
  Module zope.schema._bootstrapfields, line 138, in validate
  Module zope.schema._field, line 311, in _validate
ConstraintNotSatisfied

Steps to reproduce:

  1. create a vanilla plone instance
  2. export portlets configuration via "portal_setup"
  3. import the tarball created in step 2

The failure is in the "SearchableTextSource"-vocabuary of plone.app.vocabularies. The __contains__-method only allows objects found in the catalog. which is not true for the site (root) itself.

Seen on Plone 3.1.4 and 3.1.5 (svn/unreleased)

Attachments

patches.py Download (985 bytes) - added by tom_gross 5 years ago.
I use this patch since Plone 3.1

Change History

comment:1 Changed 5 years ago by hannosch

  • Owner optilude deleted
  • Component changed from Portlets to Infrastructure

Changed 5 years ago by tom_gross

I use this patch since Plone 3.1

comment:2 Changed 5 years ago by claytron

  • Keywords TuneUp17 forqa added

tagging this so it gets taken a look at during the next tune-up

comment:3 Changed 5 years ago by amleczko

  • Status changed from new to assigned
  • Owner set to amleczko

comment:4 Changed 5 years ago by amleczko

  • Status changed from assigned to closed
  • Resolution set to fixed

fixed with r27925

comment:5 Changed 4 years ago by WouterVH

(In [34333]) apply the patch from branches/1.x aslo on trunk, see #8380

comment:6 Changed 22 months ago by davisagli

  • Component changed from Infrastructure to General
Note: See TracTickets for help on using tickets.