Ticket #9540 (closed Bug: fixed)

Opened 5 years ago

Last modified 4 years ago

Catalan flag for language selection not appearing

Reported by: ahoms Owned by: ramon
Priority: minor Milestone: 3.3.5
Component: Internationalization Version:
Keywords: catalan flag Cc:

Description

From Plone 3.17 (and I think also in earlier versions of the 3.x) catalan flag doesn't appear to select language, it appears text

Solved adding the gif I attach in plone.i18n-XXX.egg/plone/i18n/locales/browser/language-flags/ and editing the plone.i18n-XXX.egg/plone/i18n/locales/languages.py to point the language to the gif flag

u'ca' : {u'native' : 'Català', u'name' : 'Catalan',                            u'flag' : u'/++resource++language-flags/cat.gif'},

Hope this can fix in new versions

Attachments

cat.gif Download (385 bytes) - added by ahoms 5 years ago.
Catalan Flag (obtained from Plone 2.x series)

Change History

Changed 5 years ago by ahoms

Catalan Flag (obtained from Plone 2.x series)

comment:1 Changed 4 years ago by ramon

  • Owner set to ramon

comment:2 follow-up: ↓ 3 Changed 4 years ago by ramon

  • Status changed from new to closed
  • Resolution set to fixed

comment:3 in reply to: ↑ 2 Changed 4 years ago by ahoms

  • Status changed from closed to reopened
  • Resolution fixed deleted

Replying to ramon:

Not solved in 3.3.5 release, solves also with solution added in changeset 30772  http://dev.plone.org/plone/changeset/30772. Don't know why isn't implemented in this version

comment:4 Changed 4 years ago by vincentfretin

  • Status changed from reopened to closed
  • Resolution set to fixed

(In [38437]) Backported some fixes from the trunk (closes #9540)

Note: See TracTickets for help on using tickets.