Ticket #9804 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

"Compare" from "versions_history_form" causes "KeyError: 'current_page_url'"

Reported by: kleist Owned by: alecm
Priority: major Milestone: 4.0
Component: Versioning Version:
Keywords: Cc:

Description

Plone 4 coredev buildout rev. 31767

  1. Create a page
  1. Publish it
  1. Edit it
  1. Click the "History" collapsible
  1. Click any "View this revision" link
  1. Click any of the "Compare... " links
    2009-11-17 19:42:41 ERROR Zope.SiteErrorLog 1258483361.160.482992533935 http://localhost:8080/Plone2/index/version_diff
    Traceback (innermost last):
      Module ZPublisher.Publish, line 127, in publish
      Module ZPublisher.mapply, line 77, in mapply
      Module ZPublisher.Publish, line 47, in call_object
      Module Shared.DC.Scripts.Bindings, line 324, in __call__
      Module Shared.DC.Scripts.Bindings, line 361, in _bindAndExec
      Module Products.CMFCore.FSPageTemplate, line 240, in _exec
      Module Products.CMFCore.FSPageTemplate, line 180, in pt_render
      Module Products.PageTemplates.PageTemplate, line 80, in pt_render
      Module zope.pagetemplate.pagetemplate, line 115, in pt_render
      Module zope.tal.talinterpreter, line 271, in __call__
      Module zope.tal.talinterpreter, line 343, in interpret
      Module zope.tal.talinterpreter, line 888, in do_useMacro
      Module zope.tal.talinterpreter, line 343, in interpret
      Module zope.tal.talinterpreter, line 533, in do_optTag_tal
      Module zope.tal.talinterpreter, line 518, in do_optTag
      Module zope.tal.talinterpreter, line 513, in no_tag
      Module zope.tal.talinterpreter, line 343, in interpret
      Module zope.tal.talinterpreter, line 946, in do_defineSlot
      Module zope.tal.talinterpreter, line 343, in interpret
      Module zope.tal.talinterpreter, line 533, in do_optTag_tal
      Module zope.tal.talinterpreter, line 518, in do_optTag
      Module zope.tal.talinterpreter, line 513, in no_tag
      Module zope.tal.talinterpreter, line 343, in interpret
      Module zope.tal.talinterpreter, line 376, in do_startEndTag
      Module zope.tal.talinterpreter, line 405, in do_startTag
      Module zope.tal.talinterpreter, line 482, in attrAction_tal
      Module Products.PageTemplates.Expressions, line 202, in evaluateText
      Module zope.tales.tales, line 696, in evaluate
       - URL: file:e:\buildout\plone4coredev\eggs\products.cmfeditions-2.0a1-py2.6.egg\Products\CMFEditions\skins\CMFEditions\version_diff.pt
       - Line 9, Column 4
       - Expression: <PathExpr standard:u'current_page_url'>
       - Names:
          {'container': <PloneSite at /Plone2>,
           'context': <ATDocument at /Plone2/index>,
           'default': <object object at 0x01DB0758>,
           'here': <ATDocument at /Plone2/index>,
           'loop': {},
           'nothing': None,
           'options': {'args': ()},
           'repeat': <Products.PageTemplates.Expressions.SafeMapping object at 0x075517D8>,
           'request': <HTTPRequest, URL=http://localhost:8080/Plone2/index/version_diff>,
           'root': <Application at >,
           'template': <FSPageTemplate at /Plone2/version_diff used for /Plone2/index>,
           'traverse_subpath': [],
           'user': <PloneUser 'kleist'>}
      Module zope.tales.expressions, line 217, in __call__
      Module Products.PageTemplates.Expressions, line 127, in _eval
      Module zope.tales.expressions, line 118, in _eval
    KeyError: 'current_page_url'
    

Change History

comment:1 Changed 4 years ago by alecm

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r102910 of Products.CMFEditions

comment:2 Changed 4 years ago by kleist

The bug is still there (Plone 4 coredev buildout rev. 31940), and when i click the link above trac says:

Error: Invalid Changeset Number
No changeset 102910 in the repository

comment:3 Changed 4 years ago by alecm

The link is auto-generated and always points to the plone repository. CMFEditions is in the collective repository:

 http://dev.plone.org/collective/changeset/102910

I could not reproduce this error after this change was made. You need at least r31936 of the buildout so you get the Products.CMFEditions source package (which you appear to have). Make sure to run bin/develop update.

Note: See TracTickets for help on using tickets.